dedizierte graka nutzen

  • hallo,

    ich zocke an einem notebook...leider ist es mir noch nicht gelungen metin über die grafikkarte laufen zu lassen...der client nuzt lediglich die cpu als graka. wenn ich irgendwie im nvidia versuche das spiel hinzuzufügen klappt es nicht, da er nur .exe annehmen möchte.

    hat da irgendwer schon ne lösung?

    danke schonmal im vorraus

  • ich zocke an einem notebook...leider ist es mir noch nicht gelungen metin über die grafikkarte laufen zu lassen...der client nuzt lediglich die cpu als graka.

    Wie genau meinst Du das? Läuft das Spiel nur mit der Auswahl im Spielclient "CPU"? Und bei der Auswahl "GPU" nicht? Oder bist Du sicher, dass da 2 Karten drin sind... eine integrierte am Chip und die dedizierte mit eigenem Speicher? Dann könnte man nämlich die Onboard-Karte einfach im Geräte-Manager deaktivieren, um die Nutzung der dedizierten zu erzwingen.


    Im Zweifel wäre erstmal interessant, um welches Gerät genau es sich handelt. Sprich Typ und Bezeichnung des Notebooks.

  • ich habe alles erdenkliche und findbare im nvidia systemtreiber was nur im geringtesten mit M2 zu tun hat auf hochleistungsGPU geklickt. wenn ich den patcher starte springt die dedizierte gpu auch 2 mal sehr kurz an. das sehe ich im taskmanager. wenn der client jedoch gestartet ist bleibt die nvidia gpu bei 0% auslastung. die intel hd onbord dagegen rattert fröhlich los.

    die onbord gpu komplett lahmlegen kommt eigentlich nicht in frage, da ich das notebook auch gerne mal ohne netzkabel nutze und der der akkuverbrauch so in die höhe geht, das ich so keinen 2 std spielfilm mehr anschauen kann.

    das system ist ein alienware m15 r2 mit einem i7 6820 hk, einer gtx980m mit glaube 8 oder 16 gb

  • wenn der client jedoch gestartet ist bleibt die nvidia gpu bei 0% auslastung. die intel hd onbord dagegen rattert fröhlich los.

    Weil sich der Client seine Grafikkarte selbst auswählt. Müsste eigentlich in der editierbaren Logfile stehen in den M2-Dateien. Da wo auch die Auflösung des Clients manuell editiert werden kann.


    Laggt die Grafik eigentlich oder warum soll die nicht onboard laufen? M2 müsste doch locker von einer onboard bedient werden können?


    die onbord gpu komplett lahmlegen kommt eigentlich nicht in frage, da ich das notebook auch gerne mal ohne netzkabel nutze und der der akkuverbrauch so in die höhe geht, das ich so keinen 2 std spielfilm mehr anschauen kann.

    Das war die einfachste Lösung bzw. falls es keine andere gibt. Die Karte kann man auch mit wenigen Klicks wieder reaktivieren und den PC fix neu starten.


    Apropos: Eventuell reicht es sogar, die Karte einmalig zu deaktivieren, dann den PC neu zu starten und zu sehen, was der M2client macht. Wählt der sich die dedizierte, nutzt er die eventuell auch später weiter bei reaktivierter onboard.

  • laggen tuts erst nicht.. ich bekomme aber recht schnell einfrierungen der shops und dann auch laggs an den aktiv gespielten clients. hinzu kommt das die cpu spürbar warm wird. das wäre bei der gtx nicht der fall, da sie einen extra lüfter hat.

    ich habe jetzt mal die onbord deaktiviert. wenn ich metin starte kommt die fehlermeldung:

    Metin2.CREATE_NO_APPROPRIATE_DEVICE

  • Metin2.CREATE_NO_APPROPRIATE_DEVICE

    Wahrscheinlich erwartet der Client jetzt die vorher gefundene onboard (was von Vorteil ist, wenn man ihm einmal die dedizierte "unterjubelt"). Eventuell das Spiel mal deinstallieren und neu aufgesetzt bei deaktivierter Karte starten.


    Möglich ist allerdings auch, dass der Client in Kombi mit der dedizierten Karte mit der Desktop-Auflösung nicht klarkommt. Sprich mal paar andere Auflösungen des Bildschirms probieren und sehen, ob eine den Start erlaubt. Oder über den HDMI-Ausgang testweise einen Bildschirm oder Fernseher anschließen. Dort kann der Client die Auflösung nicht prüfen und auch kein Problem damit haben.

  • habe nun auch mal versucht counterstrike zu starten mit deaktivierter onbord. funzt auch net. also nvidia treiber neu gedownloadet und installiert. geht immer noch nicht. bekomme erst wieder die beiden spiele gestartet wenn die onbord wieder mit aktiv ist. bei metin macht die gtx immernoch rein garnix und bei cs laufen beide gpus gleichzeitig. ich verzweifel langsam....


    metin eben neu downloaden geht net so schnell, ich hab nur ne 2000er leitung hier aufm holzdorf^^

  • Meine GPU - Geforce GTX 1650, Metin2 läuft ständig über Intel HD also die intergrierte, gibt es da eine Lösung ?

    Was ich bisher getan habe :


    1.Nvidia Systemsteuerung alles erdenkliche hinzugefügt was auf Höchstleistung laufen soll.

    2.Firewall Anti Virus etc alles überprüft

    3.Treiber aktualisiert

    4.Kompatibiltät geprüft

    5. In Game Einstellungen bei Config


    Warum nimmt der nicht die GPU sondern diese billig Intel HD Grafikkarte..


    bitte helft mir..

  • Ferndiagnosen Sind wie ein Lotterielos bei sowas, würde mal den Herrsteller anrufen oder in einem Computer-Fachgeschäft (nicht Mediamarkt etc) fragen.

    Vielleicht ist dem Hersteller auch so ein Fehler bei dem Gerät bekannt.

    Name: iBlackForest
    Server: Genesis
    Rasse: Nahkampf-Ninja
    Lvl: 120
    Gilde: TheOneRing
    Reich: Gelb

  • Ferndiagnosen Sind wie ein Lotterielos bei sowas, würde mal den Herrsteller anrufen oder in einem Computer-Fachgeschäft (nicht Mediamarkt etc) fragen.

    Da ist google xMal effektiver. Ein "Computerfachmann" kann da mit hoher Wahrscheinlichkeit nicht weiterhelfen, gerade ohne Kenntnis der betreffenden Software. Metin2 ist einfach eigenartig konzipiert. Man ruft mit einer .bin eine .exe auf und gibt damit schon diverse Einstellmöglichkeiten ab für den Start und Diagnosen.

    Das Problem ist, dass hier zweit Grafikkarten verbaut sind. Eine für den "Leerlauf", um Energie zu sparen und eine, wo es mehr Leistung braucht. Webzen hat aber möglicherweise gewisse Standards nicht eingehalten und nun erkennt Windows nicht automatisch, dass es sich um eine Anwendung mit Grafikanforderungen handelt. Bzw. ist da wahrscheinlich auch die Grafikkarten-Managementsoftware im Spiel und kann mit "Metin2" nichts anfangen, weil es sich exotisch verhält.



    Eventuell kann man noch versuchen, im Bios die Energiesparoptionen zu deaktivieren, so dass die leistungsfähigere Karte favorisiert wird.

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von WunRo ()